Welcome guest, is this your first visit? Create Account now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

This is a discussion on Chrome Crashes WAY too much within the Bugs and Vulnerabilities section, part of the Google Chrome category: I have been using chrome since it was a beta. I am extremely impressed with it. In the last 2 ...


  1. #1
    FLeastwood is offline Junior Member
    Join Date
    Apr 2009
    Posts
    2

    Default Chrome Crashes WAY too much

    I have been using chrome since it was a beta. I am extremely impressed with it.

    In the last 2 weeks, it has been crashing a LOT. It will crash when I have two pages loading at once. It will crash when I type something in the address bar and click search. It will crash for no particular reason when I am simply reading an email...

    I have no idea what could be causing it. My computer is new and fast, I have anti-spyware/virus.

    Anyone else dealing with this?

    I may have to take a step backwards and try chrome again in a few months... I just hate to do it because IE sucks.

  2. #2
    Stamga's Avatar
    Stamga is offline Super Moderator/Designer
    Join Date
    Mar 2009
    Location
    Qc, Canada
    Posts
    601

    Default

    As I tell everybody else who have problems with Chrome, try changing channel using the Chrome Channel Chooser. Don't forget to update Chrome after changing channel.


  3. #3
    StevePaul's Avatar
    StevePaul is offline Senior Member
    Join Date
    Mar 2009
    Location
    Birmingham, England
    Posts
    1,522

    Default

    In my experience Chrome is pretty stable on whatever channel you are on ...

    Your post seems to suggest it was working OK at some point in time ...

    Although you've got antispyware and virus protection installed I would suggest you run a complete scan of your installation ....

    Malwarebytes and Superantispyware are extremely good ...

  4. #4
    FLeastwood is offline Junior Member
    Join Date
    Apr 2009
    Posts
    2

    Default

    So I think I have it mostly isolated. I switched to stable mode but it didn't do anything.

    I crashes within a couple of seconds after I attempt to search by using the address bar.

    Scanned system... came back clean.

    Any ideas?

  5. #5
    StevePaul's Avatar
    StevePaul is offline Senior Member
    Join Date
    Mar 2009
    Location
    Birmingham, England
    Posts
    1,522

    Default

    What OS are you using ...
    Have you recently updated any software or anything else...
    What version of Chrome are you on ...
    Last edited by StevePaul; 04-19-2009 at 02:57 AM. Reason: Added to questions

  6. #6
    Luc VN's Avatar
    Luc VN is offline Senior Member
    Join Date
    Sep 2008
    Location
    Belgium - Europe
    Posts
    758

    Default

    Fleastwood,

    I find Chrome extremely stable (no crashes at all) for now and I use the DEV channel:

    Google Chrome 2.0.174.0 (Official Build 13645)
    WebKit 530.6
    V8 1.1.8

    So I think it must be something else in your system...

    Kind Regards,

    Luc VN

  7. #7
    StevePaul's Avatar
    StevePaul is offline Senior Member
    Join Date
    Mar 2009
    Location
    Birmingham, England
    Posts
    1,522

    Default

    @Luc VN

    I'm with you on this, I read most of the blogs with reference to issues with Chrome and there doesn't appear to be major problems on any of the channels, certainly no continual crashes.

    @Fleastwood

    As a last resort, suggest you uninstall Chrome and reinstall (on whatever channel) I still don't believe it's an issue with Chrome.

  8. #8
    ducktape is offline Senior Member
    Join Date
    Apr 2009
    Location
    Oregon
    Posts
    213

    Default

    I have the same problem, like every page now has an: Aw, snap! It started happening after the last Dev Update (the one that you can edit the thumbnails in). So now I mostly use Firefox, and I hope to go back to Chrome with the next Dev Update. Maybe it'll fix it self or something. Oh and it can display the basic Gmail but not the standard one. I hope someone finds a solution or what's causing the problem.

  9. #9
    Stamga's Avatar
    Stamga is offline Super Moderator/Designer
    Join Date
    Mar 2009
    Location
    Qc, Canada
    Posts
    601

    Default

    Well, if you want to stay with Chrome, you can just downgrade to the Beta channel till there's a new Dev release..


  10. #10
    StevePaul's Avatar
    StevePaul is offline Senior Member
    Join Date
    Mar 2009
    Location
    Birmingham, England
    Posts
    1,522

    Default

    Still don't believe this is a Chrome problem ...

    There are no similar reports for Dev version 2.0.174.0 ...

Page 1 of 2 12 LastLast

Similar Threads

  1. Frequent crashes with multiple tabs
    By Illway in forum Bugs and Vulnerabilities
    Replies: 3
    Last Post: 03-04-2010, 05:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •