Welcome guest, is this your first visit? Create Account now to join.
Results 1 to 3 of 3

This is a discussion on Browsing problem in G/Chrome within the Chrome Talk section, part of the Google Chrome category: http://tdw3.globeinvestor.com I don't encounter any problem when using IE browser in signing in to the above web address and thereafter ...


  1. #1
    zubcan is offline Junior Member
    Join Date
    Sep 2008
    Posts
    1

    Default Browsing problem in G/Chrome

    http://tdw3.globeinvestor.com

    I don't encounter any problem when using IE browser in signing in to the above web address and thereafter go to a sub-page through the main page. However, when I sign in using Google Chrome I can sign in to the main page but when I click on to go to a sub page "Tracker" I get the following error message:
    Microsoft Internet Explorer 4 or Netscape x4.. is required to run the tracker

    I have installed IE7 in my system. Why am I getting this error message when using Google Chrome? It does not allow me to proceed thereafter.

    Any suggestion to resolve this issue will be highly appreciated.

  2. #2
    googlefan is offline Junior Member
    Join Date
    Sep 2008
    Posts
    2

    Default

    I think the problem is with the web site you are visiting. The page you are trying to access isn't configured with other browsers than IE7 Or FireFox, so use one of them (I suggest FireFox). It takes time to Google Chrome to be Well identified by web pages.

  3. #3
    Chrome's Avatar
    Chrome is offline Administrator
    Join Date
    Sep 2008
    Posts
    345

    Default

    Yes as Googlefan said, it's the way the website has been coded and isn't directly to do with Chrome.

    Sometimes sites do that if their page doesn't run properly on other browsers instead of fixing it and making it cross-browser compliant.

    Here is their browser detection:

    function verifyBrowser()
    {
    /* var agt = navigator.userAgent.toLowerCase();
    major = parseInt(navigator.appVersion);
    minor = parseFloat(navigator.appVersion);
    nav = ((agt.indexOf('mozilla') != -1) && ((agt.indexOf('spoofer') == -1)
    && (agt.indexOf('compatible') == -1)));
    nav4up = (nav && (major >= 4));
    nav6up = (nav && (major >= 5));
    ie = (agt.indexOf("msie") != -1);
    ie4up = ie && (this.major >= 4);
    if (nav6up || (!nav4up && !ie4up))
    {
    alert("Microsoft Internet Explorer 4 or higher, or Netscape 4.XX is required to run the Tracker.");
    return false;
    }
    return true;*/
    }
    You can see the error alert your receiving in their code. They also have different stylesheets depending on browser:

    <!-- Begin
    var name = navigator.appName;
    if (name == "Netscape")
    style_to_use=("https://tdwaterhouse.globeinvestor.com/nsstyle.css");
    else
    style_to_use=("https://tdwaterhouse.globeinvestor.com/style.css")
    document.write('<link rel=stylesheet href="' + style_to_use + '" type="text/css">');
    // End of it-->
    The site just isn't coded real well sorry, and it's something they will have to fix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •