Welcome guest, is this your first visit? Create Account now to join.
Results 1 to 3 of 3

This is a discussion on Determining minimum version? within the Plugins Development section, part of the Chrome Plugins category: Realized I need to add a minimum version requirement to an extension. How can I easily determine what that requirement ...


  1. #1
    Billiam is offline Junior Member
    Join Date
    Nov 2009
    Posts
    5

    Default Determining minimum version?

    Realized I need to add a minimum version requirement to an extension. How can I easily determine what that requirement is?

    The extension makes use tab permissions, as well as a popup browser action, but I'm not clear on (and have not been able to find) when those features were added.

    Any suggestions? Any resources I could use for this, other than sifting through tons of changelogs?

    Probably doesn't matter right now without being able to add a minimum version to the manifest.json, but it would be helpful for future api updates.

  2. #2
    sulasno's Avatar
    sulasno is offline Super Moderator
    Join Date
    Sep 2008
    Location
    Bangkok
    Posts
    1,759

    Default

    extensions are only supported in the dev version of Chrome at the moment

  3. #3
    nandayo's Avatar
    nandayo is offline Senior Member
    Join Date
    Jul 2009
    Location
    Home is where the heart is
    Posts
    160

    Default

    Quote Originally Posted by Billiam View Post
    Realized I need to add a minimum version requirement to an extension.
    Minimum browser version

    To ensure that a given extension update will apply only to Google Chrome versions at or higher than a specific version, you would add the prodversionmin parameter to the <app> tag in your update manifest.

    PHP Code:
    <?xml version='1.0' encoding='UTF-8'?>
    <gupdate xmlns='http://www.google.com/update2/response' protocol='2.0'>
      <app appid='aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa'>
        <updatecheck codebase='http://myhost.com/mytestextension/mte_v2.crx' version='2.0' prodversionmin='3.0.193.0'/>
      </app>
    </gupdate>
    This would ensure that users of this extension would autoupdate to version 2 only if they are running Google Chrome 3.0.193.0 or greater.

    See Autoupdate

    So... right now, you could create a "UPGRADE YOUR BROWSER!" extension popup. (extension version 1.0) In its manifest you could put up the above auto-update snipplet
    Version: 4.0.222.3, w/ --bookmark-menu --enable-local-storage --enable-session-storage --enable-user-scripts --enable-godmode

Similar Threads

  1. Latest Dev Version: 4.0.220.1
    By sulasno in forum Chrome Talk
    Replies: 5
    Last Post: 10-06-2009, 12:52 PM
  2. running Trunk version and Dev version simultaneously
    By shirish in forum Chrome Tips & Tricks
    Replies: 3
    Last Post: 08-25-2009, 04:33 PM
  3. Latest Version of AdSweep (1.5.9) Now Available
    By sulasno in forum Chrome Plugins
    Replies: 49
    Last Post: 06-21-2009, 10:20 PM
  4. New Dev Version: 3.0.187.0
    By devilslackey in forum Chrome Talk
    Replies: 3
    Last Post: 06-12-2009, 04:51 AM
  5. Chrome is not ICC Version 4 ready
    By Luc VN in forum Chrome Tech
    Replies: 0
    Last Post: 06-06-2009, 07:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •