Welcome guest, is this your first visit? Create Account now to join.
Results 1 to 4 of 4

This is a discussion on Messaging inside background page within the Plugins Development section, part of the Chrome Plugins category: Hi, does anybody know what a problem with communication using messaging within background page (BP). I have an extension with ...


  1. #1
    webdizz is offline Junior Member
    Join Date
    Feb 2010
    Posts
    3

    Default Messaging inside background page

    Hi, does anybody know what a problem with communication using messaging within background page (BP).
    I have an extension with content script (CS), which sends message to BP. Message from CS is handled successfully, but when I send message from BP to BP it fails. This case works when I'm in development mode e.g. BP is opened in a browser, but doesn't work when it is closed.
    Any help is appreciated.
    Thanks in advance.

  2. #2
    Waha's Avatar
    Waha is offline Senior Member
    Join Date
    Apr 2009
    Location
    Oregon
    Posts
    788

    Default

    Since you can't have multiple Background Pages in an extension, are you talking about inter-extension communication? If so that's discussed in the "Cross-extension messaging" section here.
    ~ Projects ~
    Specialized: Carapass Auction Watcher, Kongregate Chat
    Libraries: bliplib
    Tools: manifest syntax highlighting & snippits
    ~ Happy to make extensions for pay too ;D ~
    Portfolio: Search and Share

  3. #3
    webdizz is offline Junior Member
    Join Date
    Feb 2010
    Posts
    3

    Default

    Thank you for reply.
    I mean about using messaging to communicate within one background page within one extension, but now it seems not suitable and I think it's better to use MVP pattern here.
    BTW I'm using GWT for my extension.

  4. #4
    webdizz is offline Junior Member
    Join Date
    Feb 2010
    Posts
    3

    Default

    Problem was fixed.
    The issue was concerned with different Port reference. Every time I need to send a message I make a connection and receiving Port and it seems different. I've made a static reference to received Port now all works fine.

Similar Threads

  1. New Tabs Background, Quick and easy
    By Bloody_Turds in forum Chrome Themes
    Replies: 0
    Last Post: 12-28-2009, 01:16 PM
  2. Debugging Background Pages
    By Peve in forum Plugins Development
    Replies: 2
    Last Post: 09-27-2009, 06:01 PM
  3. How do you display version inside manifest
    By twinsen in forum Plugins Development
    Replies: 2
    Last Post: 08-16-2009, 11:08 AM
  4. Viewing contents of a Background page?
    By Skyd in forum Plugins Development
    Replies: 11
    Last Post: 06-20-2009, 03:00 AM
  5. Black Tabs Background? Hmm...
    By dragonic2020 in forum Chrome Talk
    Replies: 2
    Last Post: 05-16-2009, 01:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •