Yeah, never gonna be patched though, too limiting. :p This is why Chrome warns you about what sites the extension wants permission to.
After all, the one unpatchable security hole is human stupidity.