I'm glad I'm not the only one getting this error. Any updates coming soon?